Install Milvus SDK

This topic describes how to install Milvus SDK for Milvus.

Current version of Milvus supports SDKs in Python and Node.js.

Requirement

Python 3 (3.71 or later) is required.

Install PyMilvus via pip

PyMilvus is available in Python Package Index.

It is recommended to install a PyMilvus version that matches the version of the Milvus server you installed. For example, install PyMilvus v2.0.0rc7 for Milvus 2.0.0-RC7.
$ python3 -m pip install pymilvus==2.0.0rc8

Verify installation

If PyMilvus is correctly installed, no exception will be raised when you run the following command.

$ python -c "from pymilvus import Collection"

What's next

Having installed PyMilvus, you can:

Is this page helpful?
Scored Successfully!