milvus-logo
Star
0
Forks
0
快速开始

安装前提

在安装 Milvus 之前,请检查你的硬件和软件是否满足要求。

硬件要求

硬件 要求 建议配置 说明
CPU Intel CPU Sandy Bridge 或以上
  • 单机版:8 核或更多
  • 分布式版:16 核或更多
当前版本的 Milvus 不支持 AMD 和 Apple M1 CPU。
CPU 指令集
  • SSE4.2
  • AVX
  • AVX2
  • AVX-512
  • SSE4.2
  • AVX
  • AVX2
  • AVX-512
Milvus 中的向量相似度搜索和索引构建需要 CPU 支持单指令多数据 (SIMD) 扩展集。 请确保 CPU 至少支持一个列出的 SIMD 扩展集。 有关更多信息,请参阅 CPUs with AVX
RAM
  • 单机版: 16G
  • 分布式版: 64G
  • 单机版: 32G
  • 分布式版: 128G
RAM 的大小取决于数据量。
硬盘 SATA 3.0 SSD 或以上 SATA 3.0 SSD 或以上 硬盘的大小取决于数据量。

软件要求

建议你在 Linux 平台上运行 Kubernetes 集群。

kubectl 是 Kubernetes 的命令行工具。使用与集群一个次要版本差异内的 kubectl 版本。使用最新版本的 kubectl 有助于避免不可预见的问题。

在本地运行 Kubernetes 集群时需要安装 minikube。 minikube 需要 Docker 作为依赖项。确保在使用 Helm 安装 Milvus 之前安装 Docker。有关更多信息,请参阅 Get Docker

操作系统 软件 说明
Linux 发行版
  • Kubernetes 1.16 或以上
  • kubectl
  • Helm 3.0.0 或以上
  • minikube (Milvus 单机版)
  • Docker 19.03 或以上 (Milvus 单机版)
有关更多信息,请参阅 Helm Docs
软件 版本
etcd 3.5.0
MinIO RELEASE.2020-11-06T23-17-07Z
Pulsar 2.8.2

更多内容

该页面是否对你有帮助?
本页目录